Reproduce scenario

Unity update from 5.0.1 to 5.1 raised the following error with FB plugin.

This problem will repeats when new unity version is released but there is no new fb sdk yet.

Error details

error

Full error message text:

Investigation and solution

After a short research I found a problem. At FB.cs was unity version checking. And ofcourse there is no UNITY_5_1 there 🙂

As a solution just simply add new version

 

Good luck!